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General information
The exported files are always CSV files. CSV stands for "Comma separated values". This means
that a comma separates the values in the file (,).
These CSV files can be opened and edited with programs such as Microsoft Excel™, Google
Sheets™. It is also possible to import and edit with frequently used programming languages or
frameworks such as R™, Python™, Numpy™ or Tensorflow™. This guide applies to Microsoft
Excel™ and Google Sheets™.
Your settings at Excel™ and Google Sheets™ are decisive. The eSense app adapts the measured
values to the language used. In English, the numbers are usually separated by a dot. Therefore,
1.5 in the English version becomes 1,5 in the German version. So if you open the CSV file with
Excel™ or Google Sheets™ and the numbers don't make sense, it's usually because of different
languages in the eSense app and Excel™ or Sheets™.
In principle, therefore, the following applies: If you use Excel™ or Sheets™ in German, you
should also use the eSense app in German. If you use Excel™ or Sheets™ in English, you should
also use the eSense app in English. This saves you the first two steps (replacing decimal

separators and splitting values into columns) and you can start directly with step 3 (Apply skin
conductance against time).
The examples shown in this guide are mostly related to the eSense Skin Response. But the data
from the eSense Temperature, eSense Pulse and eSense Respiration can be processed in the
same way.

Exporting measured values from the Mindfield eSense app
The app also includes an archive where you can save and
export your recordings.
Export data
By clicking on the export icon in the upper right you can
export the recordings in .csv format with all common apps
(e.g. send via Messenger™, WhatsApp™, email etc.) or
simply on your phone or in your cloud (e.g. Google Drive™ or
Dropbox™).
The data is exported as.csv file (comma-separated values).
You can open this file format e.g. with Microsoft Excel™ or
Open Office Calc™ (free alternative to Excel).
If you like working with Google, Google Sheets™ (Google
Tabellen™ in German) can also be an alternative to Excel for
you. You can also open and visualize your exported.csv files
and easily access them from multiple devices via the cloud.
Google Spreadsheets has almost the same functions as Excel
and a very similar operation.

Microsoft Excel™
1. Replace decimal separator (only necessary if you have different language settings in Excel™
and the eSense app)
1.1. Press Ctrl+H (search and replace).
1.2. Replace all commas "," with semicolons ";" (replace the column separator)
1.3. Replace all commas "," with periods "." (replace decimal separator)

Replace decimal seperator
1.4. (Alternatively, you can change the decimal separator used by Excel™ by default: Click File--Options--Advanced. Deactivate the item "Take over separator from operating system" and
select dot as decimal separator and comma as thousand separator.

2. Split values into columns (only necessary if you have different language settings in Excel™ and
the eSense app)
The values for time and measured value are still in the first column, separated by commas or
semicolons. You must divide them into two columns.
2.1.
2.2.
2.3.
2.4.

Select the entire first column A
Click on the "Text to columns" function in the "Data" menu
Select file type "Delimited" and click on next.
Choose the separator comma (,) or semicolon (;) depending on which character separates
the values
2.5. Click on "Next", Column data format "General", and "Finish".

Distribute values on columns

3. Draw skin conductance against time
3.1. Mark both columns (Seconds and Micro Siemens/Celsius/Fahrenheit) completely (Tip: click
with the mouse into the column where "MicroSiemens", “Celsius” or “Fahrenheit” is
written. Then press the CTRL and Shift keys simultaneously, hold them down, press the left,
and down arrow keys. With this abbreviation, you can quickly select both columns, even for
thousands of measured values).
3.2. Select the diagram type "Scatter" in the "Insert" menu and then the diagram type "Scatter
with smooth lines and marker". You get a diagram with the time in seconds in the horizontal
axis. Alternatively, you can also select "Line".
3.3. Note: If you are using the latest version of Excel™, you can also try "Recommended graphs".
Often Excel™ already recognizes the graph automatically.

Create diagram (points with interpolated lines and data points)

The finished diagram (Type Line) of a measurement with the eSense Skin Response

The finished diagram (Type Line) of a measurement with the eSense Temperature

The finished diagram (Type Line) of a measurement with the eSense Pulse

4. Draw skin conductance against markers
4.1. First create the diagram from the previous step 3 (Draw skin conductance against time)
4.2. In the menu under "Diagram tools” -> “Chart Design” select "Select data". A new mask will
appear
4.3. Under "Legend entries (rows)", select "Add".
4.4. Enter a series name (for example "markings") and select your markings for the row values
(in column D)
4.5. Select from the menu "Add chart element" -> "Data labels" -> "More data label options".
4.6. A menu will open on the right. There you can select "Label options" -> "Value from cells"
(and deactivate "Value" if necessary). Another mask opens and you have to mark your
marks from column D again.
4.7. If you also want the lines to the positions in the graphs, you must select "Add chart
element" -> "Drop Lines"
4.8. You can now adjust colors or fonts.

The finished diagram with markers of a measurement with the eSense Skin Response

The finished diagram with markers of a measurement with the eSense Temperature

5. Draw skin conductance against SCR
5.1. First create the diagram from the previous step 3 (Draw skin conductance against time)
5.2. In the menu under "Diagram tools” -> “Chart Design” select "Select data". A new mask will
appear
5.3. Under "Legend entries (rows)", select "Add".
5.4. Enter a series name (for example SCR") and select your SCR/min for the row values (in
column F)
5.5. In the menu under "Chart Tools" -> "Design" select "Change Chart Type". A new mask will
appear. In the tab, select “All Charts” -> “Combo” -> “Custom Combination”. For the SCR,
select "Clustered Column" from the drop-down menu and make sure that the tick next to
Secondary axis is set (see also following screenshot).

Add SCR series as grouped columns

The finished diagram with SCR

Google Drive (Google Sheets™ / Tabellen™)
As in Excel™, complications with the separators can also occur here. The exported files are
always CSV files. CSV stands for "Comma separated values". This means that a comma separates
the values in the file (,)
Google often tries to format the data automatically. Then it can happen, among other things,
that the measured values are interpreted as date. To prevent this, you should first make sure
that you select "Format" -> "Number" -> "Number".

1. Replace decimal separator (only necessary if you have different language settings in Google
Sheets™ and the eSense app)
1.1. Press Ctrl+H (search and replace).
1.2. Replace all commas "," with semicolons ";" (replace the column separator)
1.3. Replace all commas "," with periods "." (replace decimal separator)

Replace decimal seperator

2. Split values into columns (only necessary if you have different language settings in Google
Sheets™ and the eSense app)
Depending on their language settings, the values for time and measured value are both in the
first column, separated by commas or semicolons. You must divide them into two columns.
2.1. Select the entire first column A
2.2. Click on "Split text into columns" in the "Data" menu
2.3. Select file type "separate" and click on next.
2.4. Choose the separator comma (,) or semicolon (;) depending on which character separates
the values

3. Apply skin conductance against time.
3.1. Mark both columns (Second and Micro Siemens/Celsius/Fahrenheit) completely (Tip: click
with the mouse into the column where "Measured values" is written. Then press the CTRL
and Shift keys simultaneously, hold them down, press the left, and down arrow keys. With
this abbreviation, you can quickly select both columns, even for thousands of measured
values).
3.2. Select "Insert" -> "Diagram" in the menu. Note: Google Sheets™ often tries to automatically
create the right chart. Sometimes this works well, sometimes it doesn't. If the diagram does
not make sense, simply continue with the next steps.
3.3. Click on the diagram. A dialog box should open at the right margin. Select "Smoothed line
diagram" as the diagram type. For "X-axis", make sure seconds are selected. For the "series",
make sure that your measured values are selected. See also the following screenshot.

The finished diagram

4. Enter main conductance against highlights
4.1. Delete column C with the time stamp
4.2. Mark the column with your measured values and the column with your markings
simultaneously (as shown in the following screenshot)
4.3. Select "Insert" -> "Diagram" in the menu. Note: Google Sheets™ often tries to automatically
create the right chart. Sometimes this works well, sometimes it doesn't. If the diagram does
not make sense, simply continue with the next steps.
4.4. Click on the diagram. A dialog box should open at the right margin. Select "Smoothed line
diagram" as the diagram type. For the "series", make sure that your measured values are
selected. Your markings should be selected as "Labelling". See also the following screenshot

The finished diagram with markers

Streaming eSense data to a PC/Mac/Browser (eSense
Dashboard, OSC)
We offer advanced users such as biofeedback trainers, therapists and coaches the ability to stream
the measurement data of the eSense sensors via the eSense app to a PC as well. Thus, group courses
can be realized or remote training, whereby the trainee can be in a very different place than the
trainer. Even a remote supervision is easy.
All features described below are not public but available on request. In our online shop, we offer an
eSense set for professional users, where the use of these features is included in the price. After
unlocking, you can see these features in the settings in the eSense app when you scroll all the way
down.
Currently, we offer you two ways to transfer data from the eSense App to the PC: our eSense
Dashboard or the OSC Transfer. Both can even be used in parallel but usually it makes sense to use
either one of them. The OSC protocol is used for fast and timely streaming and actually comes from
the music industry. OSC is open-source and there are a lot of possibilities to integrate the protocol
into existing software.

eSense Dashboard
The eSense Dashboard is hosted on our Mindfield servers, so it's easy to access via a browser. The
eSense Dashboard is based on the Thingsboard Community Edition.
To start with the eSense Dashboard, all you have to do is enter an access token in the app. We can
provide you with a demo dashboard with the access token if you just want to give it a try. Simply
send us a short e-mail to info@mindfield.de
Our eSense Dashboard does not store any data, it just serves to view real-time data (but as always,
your data will be anonymized and stored only for you locally on your smartphone in the eSense app more on that below).
With the eSense dashboard you can view the measurements of several and different eSenses
simultaneously and in real time. For example, you can watch and look after a group of 5 different
users, each with their own eSense. This allows an eSense Skin Response to be freely combined with
an eSense Pulse or Temperature or Respiration. At the same time, users can even be distributed
around the world. All you need is a smartphone and internet connection and the eSense Dashboard
Access Token.
We also offer help and support for setting up the eSense Dashboard for a fee.

OSC Transfer
OSC stands for "Open Sound Control" and is an open-source network protocol developed by the
University of California at Berkeley. It is widely used in the music industry because it is great for
processing different signals in real time (for example, at a concert where it is imp ortant to
match multiple microphones and lights in real time).
This makes this protocol particularly well suited for the data transmission of several eSenses in
real time. Due to the wide distribution in the music industry, there are already some extensions
and plugins which you can adjust relatively easily and use in a self-designed software. These are
usually found in all common programming languages like for Android, iOS, Java, Javascript, C
++, Python and many more.
To use OSC with the eSense app, you must define the IP address of the user receiving the data.
This can be a local IP address or an IP address on the internet. You can define the ports as you
wish. You should pay attention to firewalls, as they like to prevent the flow of data.
You can also define a variable in the app to be able to assign different eSense. This will allow
you to sort or filter the eSense (or users) and analyze it better.
The OSC transfer is aimed at programmers of (Windows or Mac) software who want to
integrate the data from the eSense. The available OSC libraries in the usual programming
languages make such integration very easy.

Notes

Have fun with the eSense!
If you have any questions, problems or suggestions, please contact us at any time at
info@mindfield.de
All trademarks, product names, trade names and logos used on these pages are the property of their
respective owners.

