/

MINDFIELD" &
BIOSYSTEMS

A Better State of Mind

Instructions for displaying eSense measured values in
Microsoft Excel™ and Google Sheets™

eSense App Version 3.2.6 | 12/02/2019

General information

The exported files are always CSV files. CSV stands for "Comma separated values". This means
that a comma separates the values in the file (,).

These CSV files can be opened and edited with programs such as Microsoft Excel™ and Google
Sheets™. It is also possible to import and edit the CSV files with programming languages or
frameworks such as SPSS™, Matlab™, R™, Python™, Numpy™ and Tensorflow™. This guide applies
to Microsoft Excel™ and Google Sheets™.

Your settings at Excel™ and Google Sheets™ are decisive. The eSense app adapts the measured
values to the language used. In English, the numbers are usually separated by a dot. Therefore,
1.5 in the English version becomes 1,5 in the German version. Because of different languages in
the eSense app and Excel™ or Sheets™, you may open the CSV file with Excel™ or Google Sheets™
and notice that the numbers don't make sense.

In principle, therefore, the following applies: If you use Excel™ or Sheets™ in German, you
should also use the eSense app in German. If you use Excel™ or Sheets™ in English, you should
also use the eSense app in English. This saves you the first 2 steps (replacing decimal separators
and splitting values into columns), and you can start with step 3 (applying skin conductance
against time).

The examples shown in this manual are mostly referring to the eSense Skin Response. In general,
you can edit the data from the eSense Temperature or the eSense Pulse in the same way.
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Exporting measured values from the Mindfield eSense app

¢ Archive Details

Messung-24072018-204202
RECORDING NAME

24.07.18 20:42:02
DATE (HH:MM:SS)

00:02:20
TIME (HH:MM:SS)

00:01:45
TIME INCREASE (HH:MM:SS)

00:00:28
TIME DECREASE (HH:MM:SS)

00:00:06
TIME STEADY

4,354
MAXIMUM

2,01uS
MINIMUM

2,344S
DIFFERENCE MIN/MAX

6 SCR
TOTAL SCR

21,3%
% of SCR OF SESSION

3,064
AVERAGE OF SESSION

The app includes an archive where you can see, compare and
export your recordings.

Export data

By clicking on the export icon in the upper right, you can
export the recordings in .csv format with all common apps
(e.g. send via Messenger™, WhatsApp™, email etc.) or simply
on your phone or in your cloud (e.g. Google Drive™ or
Dropbox™).

The data is exported as a .csv file (comma-separated values).
You can open this file format with Microsoft Excel™ or Open
Office Calc™ (free alternative to Excel).

If you like working with Google, Google Sheets™ (Google
Tabellen™ in German) can also be an alternative to Excel for
you. You can also open and visualize your exported .csv files
and easily access them from multiple devices via the cloud.
Google Spreadsheets has almost the same functions as Excel
and a very similar operation.
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Microsoft Excel™

1. Replace decimal separator (only necessary if you have different language settings in Excel™
and in the eSense app)

1.1. Press Ctrl and H (search and replace).

1.2. Replace all commas "," with semicolons ";" (replace the column separator).

1.3. Replace all commas "," with periods "." (replace decimal separator).

File Home Insert Page Layout Formulas Data Review View

Al0 M f SECOND

Find and Replace ? x KE

Find  Replace

Findwhat: |, v

Replace with: || v

Options >>

Replace All Replace Find All Find Next Close

9 |STATISTICS

10 |SECOND MICROSIEMENS
11]10.0 2,63
1211.0 2,56/

13(2.0 237

Replacing decimal separator

1.4. Alternatively, you can change the decimal separator used by Excel™ by default: Click File---
Options--Advanced. Deactivate the item "Take over separator from operating system" and
select dot as decimal separator and comma as thousand separator.

2. Split values into columns (only necessary if you have different language settings in Excel™ and
in the eSense app)

The values for time and measured value are still in the first column, separated by commas or
semicolons. You must divide them into two columns.

2.1. Select the entire first column A.

2.2. Click on the "Text to columns" function in the "Data" menu.

2.3. Select file type "Delimited" and click on next.

2.4. Choose the separator comma (,) or semicolon (;), depending on which character separates
the values.
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2.5. Click on "Next", Column data format "General", and "Finish".

A B C D E F G H I ) K L M N o P (-
1 [DESCRIPTIONVALUE ~ TIMESTAMP
2 |RECORDING |Messung-05062015-140304 Convert Text to Columns Wizard - Step 2 of 3 7 X
S| BRI waisiuinisis This screen lets you set the delimiters your data contains. You can see how your text is affected
4 [nvE (H:m|  00:23:17 in the preview below.
5 |MAXIMUM |6.84us Delimiters
6 [MiNIMUM [1.1205 Omb
7 El5,72u5 A semicolon [ Treat consecutive delimiters as one
8 omma
o [sTaTisTICS g ipau 1ot sastios t
10[SECOND  |MICROSIEMETIMESTAMP MARKER O gther
n 0 2,62 14:03:04:095
2 1 :
= 3 Data preview
14 3
15 4 Ll
16 s
17 5 .
18 7| v 780 840 900 960 1020 1080 1140 1200 1260 1320 1380
19 8
20 9
= o cancel <Back Finish
22 11 4
2 12 2.85 12:03:16:085

Vorlage Skin_Response EN 3

Splitting values into columns

3. Draw skin conductance against time

3.1. Mark both columns (Seconds and Micro Siemens/Celsius/Fahrenheit) completely (Tip: with

3.2.

3.3.

the mouse, click into the column where "MicroSiemens", “Celsius” or “Fahrenheit” is
written. Press the CTRL and Shift keys simultaneously, then hold those keys down and press
the left and down arrow keys. With this abbreviation, you can quickly select both columns,
even for thousands of measured values).

Select the diagram type "Scatter" in the "Insert" menu and then the diagram type "Scatter
with smooth lines and marker". You get a diagram with the time in seconds in the horizontal
axis. Alternatively, you can also select "Line".

Note: If you are using the latest version of Excel™, you can also try "Recommended graphs".
Often Excel™ already recognizes the graph automatically.

File Home [MUESGN Pagelayout  Formulas  Data  Review  View  Q Tell mewhat you wantto do
’J 5 e FS;:::Plcluvn » | @ysione ”_? .| ,I"- .l'. (D I[-‘_ |’—pj "~ i I""' :—;
~ D M hY ¥ &
PivotTable Re;:z\tr::br;z:d Table Pvﬁuves"r lons o @ Myaddins - B Re(og:;:snded 9 BB ' M?ps Pl\.'ot'Chan Msa[;' Line Column \Lvo»zs Slicer
Tables IHlustrations Add-ins Scatter Tours Sparklines F
B10 ” fe || MICROSIEMENS N
. . . .
A B c D E F G H K L M

1 |DESCRIPTION VALUE TIMESTAMP

2 |RECORDING Messung-05062018-140304

3 DATE (HH:MI sstssssng
4 |TIME (HH:MN  00:23:17

5 MAXIMUM 6.84uS
6 [MINIMUM  1.12pS

7 |DIFFERENCE 5,728
8

9 |STATISTICS
10 [SECOND | MICROSIEME[TIMESTAMP MARKER
11 0 2,62(14:03:04:095
12 1 2,54/14:03:05:095
13 2 2,7|14:03:06:095
14 3 2,7(14:03:07:095
15 4 2,71(14:03:08:095
16 5 2,83
17 6 27
18 7 2,58 £
19 8 2,5[14:03:12:095
an a 2 l1a:n2:12:n05

Create graph (Scatter with Smooth Lines and Markers)
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1 |BESCHREIBUI WERT

2 |NAME MESSI Messung-05062018-140304
3 |DATUM (SS:N sty

4 |ZEIT (SS:MM: 00:23:17

5 |MAXIMUM  6.84us

6 [MINIMUM  1.12pS

7 |DIFFERENZ N 5,72uS

8

9

|sTaTISTIK

ZEITSTEMPEL MARKIERUNG

Skin Response Messung

g

10 |SEKUNDE | MIKROSIEME|ZEITSTEMPEL ING g
11 0 2,62|14:03:04:095 4
12 i 2,54 =
13 2 2,7, =
14| 3 2,7
15 4 2,71(14:03:08:095
16| 5 2,83(14:03:09:095
17| 6 2,7[14:03:10:095
18 7| 2,58|14:03:11:095 360 420 480 540 600 660 720 780 B840 900 960 1020 1080 1140 1200 1260 1320 1380
19| s 2,5/14:03:12:095 Sekunden
20| 3 2,5/14:03:13:095 o L
21 10 2,6814:03:14:095

Vorlage Skin_Response DE ® [ >
Bereit Mittelwert: 112,2195843  Anzahl: 1335 Summe: 9987543 | [ EES 1 —+  100%

The finished diagram (Type Line) from a measurement with the eSense Skin Response

A B C

D

1 [DESCRIPTION .IVALUE

2 |RECORDING NAN Messung-25072018-101733

3 |DATE (HH:MM:S¢  25.07.2018 10:17

4 |TIME (HH:MM:SS 00:07:57

5 |MAXIMUM 33,09°C

6 |MINIMUM 30,06 °C

7 |DIFFERENCE MIN3,03 °C

8 |AVERAGE OF SES 31,87 °C

9 |TIME INCREASE ( 00:04:09

10 |TIME DECREASE ( 00:03:11
1 |TIME STEADY 00:00:36

13 |What is your pos Sitting on a chair
14 |Electrode fixatio Holding

15 How do you feel 8
16 |Your notes: Excercises

19 |STATISTIC

20 |SECOND Celsius
21 0

22 1 30.94 18:
231 30.96 18:37:.

TIMESTAMP MARKER

TIMESTAMP MARKER
30.92 18:37:33:936

D

Temperature Measurement

360
Sekunden

Vorlage Skin_Response DE |

®

<« | ]

The finished diagram (Type Line) from a measurement with the eSense Temperature

A B
1 DESCRIPTION VALUE
2 RECORDING NAME 5 Minutes N\
3 DATE (HH:MM:SS) 09.12.18 14,
4 TIME (HH:MM:5S) 0:05:00
5 MAXIMUM 101.9 HR
6 MINIMUM 51.9 HR
7 DIFFERENCE MIN/MAX 50.00 HR
8 AVERAGE OF SESSION 64.94 HR
9 Increase of HRV amplitude 0:02:32
10 Steady of HRV amplitude 0:00:13

11 Decrease of HRV amplitude  0:02:13
12

13 SDNN 61.267 ms
14 RMSDD 57.7711 ms
15 NN50 101
16 pNNSO 30.89%
17 Stress Index 43.61
18 AVERAGE RR 936.0 ms
19 AVERAGE HR 64.1HR

20 Corrected HR values 1
21 Corrected HR values in % 0.30%

Vorlage | @

The finished diagram (Type Line) from a measurement with the eSense Pulse
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4. Draw skin conductance against markers

4.1. First create the diagram from the previous step 3 (Draw skin conductance against time).

4.2. In the menu under "Diagram tools” -> “Design”, select "Select data". A new mask will
appear.

4.3. Under "Legend entries (rows)", select "Add".

4.4. Enter a series name (for example "markings") and select your markings for the row values
(in column D).

4.5. Select from the menu "Add chart element" -> "Data labels" -> "More data label options".

4.6. A menu will open on the right. There you can select "Label options" -> "Value from cells"
(and deactivate "Value" if necessary). Another mask opens, and you have to mark your
marks from column D again.

4.7. If you also want the lines to the positions in the graphs, you must select "Add chart

element" -> "Drop Lines".
4.8. You can now adjust colors or fonts.

A B C D E F G H 1 J K| L M N | o [

[ I»]

1 |DESCRIPTION VALUE TIMESTAMP
2 |RECORDING Messung-05062018-140304
3 |DATE (HH:MI ##u##ussng

4 |TIME (HH:MM 00:23:17

5 IMAXIMUM 6.84uS

6 MINIMUM  1.12uS

7 |DIFFERENCE 5,72uS
8

9 |STATISTICS
10 SECOND

A
2
§
£

3
e

=

s

MICROSIEMETIMESTAMP MARKER
2,62 14:03:04:095

1

13| 2 I

14] 3 2 8

15 4 5 g S £ 58 s g2 85

g ] E 5 3 5 g8 % g T8 is

16 5 B 2 2 2 = 2 86 3 §2 a8
& ] ® B 5 T = o} k) 2 23 5

17 6 2 8 8 8 & 8 £ 2 8 58 &
Jil £ £ £ £ < £

18 7 8 t & a &

19 s

20 9

21 10

22 1

23| 2.85 14:03:16:095

Vorlage_Skin_Response EN @ [«

The finished diagram with markers from a measurement with the eSense Skin Response

A B [E D | E F G H | J | K L M N o

1 |DESCRIPTION .IVALUE TIMESTAMP MARKER
2 |RECORDING NAN Messung-25072018-101733

3 |DATE (HH:MM:S¢  25.07.2018 10:17

4 |TIME (HH:MM:SS 00:07:57

5 |MAXIMUM 33,09°C

6 |MINIMUM 30,06 °C

7 |DIFFERENCE MIN3,03 °C

8 |AVERAGE OF SES 31,87 °C

Temperature Measurement

9 |TIME INCREASE ( 00:04:09
10 |TIME DECREASE ( 00:03:11
11 |TIME STEADY 00:00:36

13 |What is your pos Sitting on a chair
14 |Electrode fixatio Holding

15 |How do you feel 8
16 |Your notes: Excercises

7 § g 5 i 8

18 | § £ £ 5
;2 g g 5 §

19 |STATISTIC 2 % 5 2 s 8 &

9 g &

20 SECOND Celsius TIMESTAMP MARKER £ =

21 0 30.92 18:37:33:936 <

22| 1 30.94 18:37:34:936

23] 2 30.96 18:37:35:936

Vorlage _Skin_Response DE ® [d
The finished diagram with markers from a measurement with the eSense Temperature
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5. Draw skin conductance against SCR (just for the eSense Skin Response)

5.1. First create the diagram from the previous step 3 (Draw skin conductance against time).

5.2. In the menu under "Diagram tools” -> “Design”, select "Select data". A new mask will
appear.

5.3. Under "Legend entries (rows)", select "Add".

5.4. Enter a series name (for example "SCR") and select your markings for the row values (in
column F).

5.5. In the menu at “Chart tools” -> “Design”, choose “Change Chart type”. A new mask will
appear. In the tab “All charts” -> “Combo” -> “Custom Combination”, choose the SCR
“Clustered Column” in the dropdown menu and make sure that the tick at “Secondary axis”
is set (see also following screenshot).

Change Chart Type ? X
Recommended Charts
&> Recent \/
Templates M Mﬂi |_|ﬂ_|:h—‘ m:”‘i‘
lud Column ./
& Line Custom Combination
@ Pie
E Bar
@ Area
[ XV (Scatter)
@ Map
lisi  Stock
@ Surface
‘_’.1;’ Radar
Bﬂ Treemap
“—R' Sunburst Choose the chart type and axis for your data series:
ifly Histogram | series Name Chart Type Secondary Axis|
[is  Box & Whisker MIKROSIEMENS Line v O
M Waterfall
B e B sCrR Clustered Column v
iy Combo
Cancel

Add SCR series as Clustered Column
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A B [
1 |DESCRIPTION
2 |RECORDING NAME Calculating Skin Response Measurement
3 |DATE (HH:MM:SS) 30.06.2018 12:57
4 |TIME (HH:MM:SS) 00:38:28
5 MAXIMUM 15,37us
6 |MINIMUM 1,550
7 | DIFFERENCE MIN/MAX 13,828
8 |AVERAGE OF SESSION 7.47p5
9 | TIME INCREASE (HH:MM:SS) 00:24:44 "
IME DECREASE (HH:MM:SS) 00:10:25 §
ME STEADY 00:03:16 é
el £
13 |TOTALSCR 139 s
14|% of SCR OF SESSION 76,40%
15 /0-5 SCR/MIN (HH:MM:SS) 00:27:46
16 /6-9 SCR/MIN (HH:MM:SS) 00:09:44
17 |10-15 SCR/MIN (HH:MM:SS) 00:00:55
00:00:00

18 |>16 SCR/MIN (HH:MM:SS)
19|

20 |What is your position?

21 |Electrode fixation:

22 |How do you feel?

|25 Iiasie mntac.

Sitting on a chair
Gel Electrodes

o"3§§§§§§§§§§§§3§§§§§§§§§

=

Seconds

Vorlage Skin Response DE | ()

<

The finished diagram with SCR

www.mindfield.de




MINDFIELD" f*==
BIOSYSTEMS

A Better State of Mind

/

Google Drive (Google Sheets™ / Tabellen™)

As in Excel™, complications with the separators can also occur here. The exported files are
always CSV files. CSV stands for "Comma separated values". This means that a comma separates
the values in the file (,).

Google often tries to format the data automatically. Then it can happen, among other things,
that the measured values are interpreted as dates. To prevent this, you should first make sure
that you select "Format" -> "Number" -> "Number".

1. Replace decimal separator (only necessary if you have different language settings in Google
Sheets™ and in the eSense app)

1.1. Press Ctrl and H (search and replace).

1.2. Replace all commas "," with semicolons ";" (replace the column separator).

1.3. Replace all commas "," with periods "." (replace decimal separator).

A El c D £ F G H
o SECOND TIMESTAMP  MARKER
11 0.0 1.48 13:11:45:588
12 (1.0 150 13:11:46:588
w20 173 13:11:47:588 Find and replace
14 (3.0 1.94 13:11:48:588
5 40 191 13:11:49:588 Find
© |50 217 13:11:50:588 Replace with
17 6.0 222 13:11:51:588
12 70 02.08 13:11:52:588 Search Specificrange $  eSense_Skin_Respor [
1 80 2.00 13:11:53:588 Matchicase
20 9.0 1.93 13:11:54:588 Match entire cell contents
21 10.0 191 13:11:55:588 Search using regular expressions Help
2 110 188 13:11:56:588 Also search within formulas
22 120 1.83 13:11:57:588
24 130 1.82 13:11:58:588 Find Replace all Done
25 140 1.80 13:11:59:588
28 150 1.80 13:12:00:588
27 |16.0 1.91 13:12:01:588

Replacing decimal separator

2. Split values into columns (only necessary if you have different language settings in Google
Sheets™ and in the eSense app)

Depending on their language settings, the values for time and measured value are both in the

first column, separated by commas or semicolons. You must divide them into two columns.

2.1. Select the entire first column A.

2.2. Click on "Split text into columns" in the "Data" menu.

2.3. Select file type "separate" and click on next.

2.4. Choose the separator comma (,) or semicolon (;), depending on which character separates
the values.

www.mindfield.de
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3. Apply skin conductance against time.

3.1

3.2.

3.3.

- o~

Mark both columns (Second and Micro Siemens/Celsius/Fahrenheit) completely (Tip: with
the mouse, click into the column where "Measured values" is written. Press the CTRL and
Shift keys simultaneously, hold those keys down, and press the left and down arrow keys.
With this abbreviation, you can quickly select both columns, even for thousands of
measured values).

Select "Insert" -> "Diagram" in the menu. Note: Google Sheets™ often tries to automatically
create the right chart. Sometimes this works well, sometimes it doesn't. If the diagram does
not make sense, simply continue with the next steps.

Click on the diagram. A dialog box should open at the right margin. Select "Smoothed line
diagram" as the diagram type. For "X-axis", make sure seconds are selected. For the "series",
make sure that your measured values are selected. See the following screenshot.

™ o00% - € % 0 .00 123~  Aral - 10 - B I & ﬁ ® H A Chart editor X

DATA CUSTOMIZE
[}

DESCRIPTION VALUE . Chart style V

RECORDING N/ Messung-05062018-140304 Skin Response Measurment
DATE (HHMM:S ###sssusy — ”
4 TIME (HH:MM'S. 00:23:17 2
MAXIMUM 6.84uS Type Charttitle
MINIMUM 1.12u8 N . | |
DIFFERENCE M 5,72uS bl | ‘\u Title text
P Al N LN Skin Response Measurment
o | STATISTICS 2 ‘ P W v ' \ 7
10 SECOND MICROSIEMENS MARKER g AN N ‘ Title fo 1
" 0,00 2,62 2 3 \;/“ \ / \J Roboto Auto
12 1,00 2,54 g *f'* I
5 2,00 2,70 . e forat
1 3,00 2,70 i B I = A
15 4,00 27
18 5,00 2,83 Serie: v
17 6,00 2,70
7,00 2,58 . o o o - L egend v
8,00 2,50 nden
9,00 2,50 * Horizontal axi v
+ = | eSense_Skin_Response_data_from_31.05.18_13_11_45_1Hz.csv ——

The finished diagram

4. Enter main conductance against highlights

4.1.
4.2.

4.3.

4.4.

Delete column C with the time stamp.

Mark the column with your measured values and the column with your markings
simultaneously (as shown in the following screenshot).

Select "Insert" -> "Diagram" in the menu. Note: Google Sheets™ often tries to automatically
create the right chart. Sometimes this works well, sometimes it doesn't. If the diagram does
not make sense, simply continue with the next steps.

Click on the diagram. A dialog box should open at the right margin. Select "Smoothed line
diagram" as the diagram type. For the "series", make sure that your measured values are
selected. Your markings should be selected as "Labelling". See also the following screenshot

www.mindfield.de




o~ Ew P 100% - € Arial 10 B I & A ® H
A s o £ s H
DESCRIPTION VALUE
RECORDING N/ Messung-05062018-140304
DATE (HHMM:S  ##isissy
4 TIME (HHMM:S! 00:23:47
MAXIMUM 6.84uS "
MINIMUM 11208 4 ki
DIFFERENCE M 5,72uS oy *V\ !
1 0N \
o | STATISTICS 2 | ok :\\‘,‘ '\‘J\ ) \ JI\
SECOND MICROSIEMENS MARKER g M\\ . f‘\"\v ‘i Nl\; \ \'J
0,00 2,62 2 YL | "W f\ \A | v
w2 1,00 2,54 - W \\4\\, Ly Y
= 2,00 2,70 - & Ml
1 3,00 2,70 \\ i f
= 4,00 27 Y
1 5,00 2,83
17 6,00 2,70
7,00 2,58
1 8,00 2,50
2 9,00 2,50
4+ = | eSense_Skin_Response_data_from_31.05.18_13_11_45_1Hz.csv

My Notes

The finished diagram with markers
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A Chart editor X

DATA

Charttype

[~

Data

Smooth line chart

ange

B10:8400,C10:C1407

Combine ranges

Horizontally

X

SERIES

AXIS

123 MICROSIEME!

LABEL Tr MARKI

Switch rows / columns

Use row 10 as headers

USTOMIZE

NS

ER

Have fun with the eSense!

If you have any questions, problems or suggestions, please contact us at any time at

info@mindfield.de

All trademarks, product names, trade names and logos used on these pages are the property of their

res pective owners.
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