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General information 
 

The exported files are always CSV files. CSV stands for "Comma separated values". This means 
that a comma separates the values in the file (,). 

These CSV files can be opened and edited with programs such as Microsoft Excel™, Google 
Sheets™. It is also possible to import and edit with frequently used programming languages or 
frameworks such as R™, Python™, Numpy™ or Tensorflow™.  

These instructions refer to Microsoft Excel™ and Google Sheets™. We recommend beginners to 
use Google Sheets™ rather than Microsoft Excel™, because it is easier to use and it often works 
better with our measurements (f.i. the seconds are not automatically prefixed to dates, see in 
the section on Excel). Google Sheets is also a bit better at quickly creating charts automatically. 
Using Excel makes more sense if you are already more familiar with Excel. 

You can find Google Sheets™ here: https://www.google.com/sheets/about/  

Your settings at Excel™ and Google Sheets™ are decisive. The eSense app adapts the measured 
values to the language used. In English, the numbers are usually separated by a dot. Therefore, 
1.5 in the English version becomes 1,5 in the German version. So if you open the CSV file with 
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Excel™ or Google Sheets™ and the numbers don't make sense, it's usually because of different 
languages in the eSense app and Excel™ or Sheets™. 

In principle, therefore, the following applies: If you use Excel™ or Sheets™ in German, you 
should also use the eSense app in German. If you use Excel™ or Sheets™ in English, you should 
also use the eSense app in English. This saves you the first two steps (replacing decimal 
separators and splitting values into columns) and you can start directly with step 3 (Apply skin 
conductance against time). 

The examples shown in this guide are mostly related to the eSense Skin Response. But the data 
from the eSense Temperature, eSense Pulse and eSense Respiration can be processed in the 
same way. 
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Exporting measured values from the Mindfield eSense app 
 

 

 
 

The app also includes an archive where you can save and 
export your recordings. 

Export data  

By tapping on the export icon in the upper right or by 
tapping the “Export as CSV File” button at the bottom  you 
can export the recordings in .csv format with all common 
apps (e.g. send via Messenger™, WhatsApp™, email etc.) or 
simply on your phone or in your cloud (e.g. Google Drive™ or 
Dropbox™).  

The data is exported as.csv file (comma-separated values). 
You can open this file format e.g. with Microsoft Excel™ or 
Open Office Calc™ (free alternative to Excel). 

If you like working with Google, Google Sheets™ (Google 
Tabellen™ in German) can also be an alternative to Excel for 
you. You can also open and visualize your exported.csv files 
and easily access them from multiple devices via the cloud. 
Google Sheets has similar functions as Excel and a very 
similar operation. 
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Microsoft Excel™ 
 

1. Replace decimal separator (only necessary if you have different language settings in Excel™ 
and the eSense app) 
 
1.1. Press Ctrl+H (search and replace). 
1.2. Replace all commas "," with semicolons ";" (replace the column separator) 
1.3. Replace all commas "," with periods "." (replace decimal separator) 

 
Replace decimal seperator 
 

1.4. (Alternatively, you can change the decimal separator used by Excel™ by default: Click File---
Options--Advanced. Deactivate the item "Take over separator from operating system" and 
select dot as decimal separator and comma as thousand separator. 
 

 
2. Split values into columns (only necessary if you have different language settings in Excel™ and 

the eSense app) 
 
The values for time and measured value are still in the first column, separated by commas or 
semicolons. You must divide them into two columns. 
 
2.1. Select the entire first column A 
2.2. Click on the "Text to columns" function in the "Data" menu 
2.3. Select file type "Delimited" and click on next. 
2.4. Choose the separator comma (,) or semicolon (;) depending on which character separates 

the values 
2.5. Click on "Next", Column data format "General", and "Finish". 
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Distribute values on columns  

 

3. Format seconds correctly (optional) 
Excel often formats the seconds in the first column automatically to a date. Unfortunately there 
is no way to disable this, it is preset by Excel. But there are a few ways to solve this: 
https://support.microsoft.com/en-us/office/stop-automatically-changing-numbers-to-dates-
452bd2db-cc96-47d1-81e4-72cec11c4ed8  
 

4. Draw skin conductance against time 
 
4.1. Select both columns. The first column with the seconds and another column with the 

measured value depending on the eSense sensor (Microsiemens for Skin Response, 
Celsius/Fahrenheit for Temperature, heart rate or RR interval or HRV amplitude for Pulse, 
RR or breaths per minute for Respiration) completely.  
Then press the CTRL and Shift keys simultaneously, hold them down, press the left, and 
down arrow keys. With this abbreviation, you can quickly select both columns, even for 
thousands of measured values).  

4.2. Select the diagram type "Scatter" in the "Insert" menu and then the diagram type "Scatter 
with smooth lines and marker". You get a diagram with the time in seconds in the horizontal 
axis. Alternatively, you can also select "Line". 

4.3. Note: If you are using the latest version of Excel™, you can also try "Recommended graphs". 
Often Excel™ already recognizes the graph automatically. 
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Create diagram (points with interpolated lines and data points) 

 

 
The finished diagram (Type Line) of a measurement with the eSense Skin Response 

 

 
The finished diagram (Type Line) of a measurement with the eSense Temperature 
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The finished diagram (Type Line) of a measurement with the eSense Pulse 

 

 

5. Draw skin conductance against markers 
 
5.1. First create the diagram from the previous step 3 (Draw skin conductance against time) 
5.2. In the menu under "Diagram tools” -> “Chart Design” select "Select data". A new mask will 

appear 
5.3. Under "Legend entries (rows)", select "Add". 
5.4. Enter a series name (for example "markings") and select your markings for the row values 

(in column D) 
5.5. Select from the menu "Add chart element" -> "Data labels" -> "More data label options". 
5.6. A menu will open on the right. There you can select "Label options" -> "Value from cells" 

(and deactivate "Value" if necessary). Another mask opens and you have to mark your 
marks from column D again. 

5.7. If you also want the lines to the positions in the graphs, you must select "Add chart 
element" -> "Drop Lines" 

5.8. You can now adjust colors or fonts. 
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The finished diagram with markers of a measurement with the eSense Skin Response 

 

 
The finished diagram with markers of a measurement with the eSense Temperature 

 

6. Draw skin conductance against SCR 
 
6.1. First create the diagram from the previous step 3 (Draw skin conductance against time) 
6.2. In the menu under "Diagram tools” -> “Chart Design” select "Select data". A new mask will 

appear 
6.3. Under "Legend entries (rows)", select "Add". 
6.4. Enter a series name (for example SCR") and select your SCR/min for the row values (in 

column F) 
6.5. In the menu under "Chart Tools" -> "Design" select "Change Chart Type". A new mask will 

appear. In the tab, select “All Charts” -> “Combo” -> “Custom Combination”. For the SCR, 
select "Clustered Column" from the drop-down menu and make sure that the tick next to 
Secondary axis is set (see also following screenshot). 
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Add SCR series as grouped columns 

 

 
The finished diagram with SCR 
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Google Drive (Google Sheets™, recommended) 
 

As in Excel™, complications with the separators can also occur here. The exported files are 
always CSV files. CSV stands for "Comma separated values". This means that a comma separates 
the values in the file (,) 

Google often tries to format the data automatically. Then it can happen, among other things, 
that the measured values are interpreted as date. To prevent this, you should first make sure 
that you select "Format" -> "Number" -> "Number". 

 

1. Replace decimal separator (only necessary if you have different language settings in Google 
Sheets™ and the eSense app) 
 
1.1. Press Ctrl+H (search and replace). 
1.2. Replace all commas "," with semicolons ";" (replace the column separator) 
1.3. Replace all commas "," with periods "." (replace decimal separator)  

 

 
Replace decimal seperator 
 
 
2. Split values into columns (only necessary if you have different language settings in Google 

Sheets™ and the eSense app) 
 
Depending on their language settings, the values for time and measured value are both in the 
first column, separated by commas or semicolons. You must divide them into two columns. 
2.1. Select the entire first column A 
2.2. Click on "Split text into columns" in the "Data" menu 
2.3. Select file type "separate" and click on next. 
2.4. Choose the separator comma (,) or semicolon (;) depending on which character separates 

the values 
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3. Apply skin conductance against time. 
 
3.1. Mark both columns (Second and Micro Siemens/Celsius/Fahrenheit) completely (Tip: click 

with the mouse into the column where "Measured values" is written. Then press the CTRL 
and Shift keys simultaneously, hold them down, press the left, and down arrow keys. With 
this abbreviation, you can quickly select both columns, even for thousands of measured 
values).  

3.2. Select "Insert" -> "Diagram" in the menu. Note: Google Sheets™ often tries to automatically 
create the right chart. Sometimes this works well, sometimes it doesn't. If the diagram does 
not make sense, simply continue with the next steps.  

3.3. Click on the diagram. A dialog box should open at the right margin. Select "Smoothed line 
diagram" as the diagram type. For "X-axis", make sure seconds are selected. For the "series", 
make sure that your measured values are selected. See also the following screenshot. 

 

 
The finished diagram 

 
 
4. Enter main conductance against highlights 

 
4.1. Delete column C with the time stamp 
4.2. Mark the column with your measured values and the column with your markings 

simultaneously (as shown in the following screenshot) 
4.3. Select "Insert" -> "Diagram" in the menu. Note: Google Sheets™ often tries to automatically 

create the right chart. Sometimes this works well, sometimes it doesn't. If the diagram does 
not make sense, simply continue with the next steps.  

4.4. Click on the diagram. A dialog box should open at the right margin. Select "Smoothed line 
diagram" as the diagram type. For the "series", make sure that your measured values are 
selected. Your markings should be selected as "Labelling". See also the following screenshot 
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The finished diagram with markers  
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Streaming eSense data to a PC/Mac/Browser (eSense Web 
App, OSC) 
 

We offer advanced users such as biofeedback trainers, therapists and coaches the ability to stream 
the measurement data of the eSense sensors via the eSense app to a PC as well. Thus, group courses 
can be realized or remote training, whereby the trainee can be in a very different place than the 
trainer. Even a remote supervision is easy. 

All features described below are not public but available on request. In our online shop, we offer 
an eSense set for professional users (https://mindfield-shop.com/en/product/professionelle-
anwender-set-exkl-sdk/), where the use of these features is included in the price. After unlocking, 
you can see these features in the settings in the eSense app when you scroll all the way down. 

Currently, we offer you two ways to transfer data from the eSense App to the PC: our eSense Web 
App or the OSC Transfer. Both can even be used in parallel but usually it makes sense to use either 
one of them. The OSC protocol is used for fast and timely streaming and actually comes from the 
music industry. OSC is open-source and there are a lot of possibilities to integrate the protocol into 
existing software. 

 

eSense Web App 
 

With the eSense Web App for iOS and Android, we have also developed an eSense web app for 
the browser, which mirrors and supplements the eSense mobile app. 

You need an account for the eSense app and one of our plans. You can analyze your recorded 
data in the browser (with the basic plan) or even stream it in real time to a PC (with the 
premium plan). With the eSense Web App you can view the measurements of several and 
different eSenses simultaneously and in real time. 

For example as professional user you can watch and look after a group of 5 different users, 
each with their own eSense. Different sensors, for example an eSense Skin Response with an 
eSense Pulse or Temperature or Respiration, can be freely combined. The users can even 
be distributed around the world. They just need a smartphone, an eSense sensor, the mobile 
app and a booked plan. More information about the plans soon here. 
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eSense Web App at a live measurement with the eSense Pulse 

 

As a private user, you can also benefit from the fact that you can see the graph even better 
with a large screen and enlarge individual areas. 

You will find the eSense Web App at https://esense.live. There you can log in with the same 
account (username and password) as for the eSense mobile app. 

 

OSC Transfer 
 

OSC (https://opensoundcontrol.stanford.edu/)  stands for "Open Sound Control" and is an 
open-source network protocol developed by the University of California at Berkeley. It is widely 
used in the music industry because it is great for processing different signals in real time (for 
example, at a concert where it is important to match multiple microphones and lights in real 
time). 

This makes this protocol particularly well suited for the data transmission of several eSenses in 
real time. Due to the wide distribution in the music industry, there are already some extensions 
and plugins which you can adjust relatively easily and use in a self-designed software. These are 
usually found in all common programming languages like for Android, iOS, Java, Javascript, C 
++, Python and many more. 
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To use OSC with the eSense app, you must define the IP address of the user receiving the data. 
This can be a local IP address or an IP address on the internet. You can define the ports as you 
wish. You should pay attention to firewalls, as they like to prevent the flow of data. 

You can also define a variable in the app to be able to assign different eSense. This will allow 
you to sort or filter the eSense (or users) and analyze it better. 

The OSC transfer is aimed at programmers of (Windows or Mac) software who want to 
integrate the data from the eSense. The available OSC libraries in the usual programming 
languages make such integration very easy. 
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Notes 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

 

Have fun with the eSense! 

If you have any questions, problems or suggestions, please contact us at any time at 
info@mindfield.de 

All trademarks, product names, trade names and logos used on these pages are the property of their 
respective owners. 

 


